Welcome Guest! To enable all features please Login or Registers.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
maxpou  
#1 Posted : Tuesday, January 12, 2021 9:41:36 PM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

Hi,
I have a S/PDIF Transceiver (WM8804) that I am using with a COD stereo mode, and i would like to know if i can plug the coax out from my cd player directly in the transceiver module or no? If not what is missing?
thank you! Maxpou
Brian Donegan  
#2 Posted : Wednesday, January 13, 2021 1:09:15 AM(UTC)
Brian Donegan

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Views messages in topic : 2,850
Location: Massachusetts, USA

Thanks: 2 times
Was thanked: 136 time(s) in 131 post(s)
Yes, that is exactly what it is for.
maxpou  
#3 Posted : Tuesday, February 2, 2021 5:45:29 PM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

Hi Brian,
i received my s/pdif transceiver and i tested in this weekend and i have a crack sound when i listen music. I have a iv common base without CFP bypass R10, COD with PCM1798 that i changed and it work perfectly because i tested it with my old cd player but it dosn't work with the s/pdif transceiver. Some pictures maybe help. Someone can help me. Thank you!Maxpou

first pic:400Hz iv output
2e: installation
3e: iv stage
4e: s/pdif input without music just cd player power on
5e:1khz iv output

400hz.jpg (36kb) downloaded 2 time(s). installation test.jpg (46kb) downloaded 5 time(s). iv stage.png (7kb) downloaded 2 time(s). spdif input.jpg (37kb) downloaded 0 time(s). 1khz.jpg (32kb) downloaded 0 time(s).

Edited by user Tuesday, February 2, 2021 5:50:13 PM(UTC)  | Reason: Not specified

Brian Donegan  
#4 Posted : Tuesday, February 2, 2021 6:21:49 PM(UTC)
Brian Donegan

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Views messages in topic : 2,850
Location: Massachusetts, USA

Thanks: 2 times
Was thanked: 136 time(s) in 131 post(s)
I would shorten the I2S lines a bit, just to prevent cross-talk between the clock/data lines (keep wires from over-lapping).

Also, it would be good to test with a simplified output (direct to DAC) and add the I/V later, just to be sure where the noise is coming from.
maxpou  
#5 Posted : Wednesday, February 3, 2021 1:45:40 AM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

Hi Brian
thank you for reply. I did some tests tonight, I shortened my lines and they are 3cm now. I also simplified the output (without my i / v stage) and put a 392 ohm resistor for r3 and r4 in COD. I have the same problem. Maxpou
1khz-1.jpg (38kb) downloaded 1 time(s). 400hz-1.jpg (33kb) downloaded 0 time(s). installation.jpg (50kb) downloaded 1 time(s).
Brian Donegan  
#6 Posted : Wednesday, February 3, 2021 2:51:47 AM(UTC)
Brian Donegan

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Views messages in topic : 2,850
Location: Massachusetts, USA

Thanks: 2 times
Was thanked: 136 time(s) in 131 post(s)
What are your switch settings on the transceiver?
maxpou  
#7 Posted : Wednesday, February 3, 2021 4:20:23 AM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

wm8804:
AIF/MS: 1
TXSRC: 0
AIFCONF1: 0
AIFCONF0: 1

COD
MONO: 0
CHSL: 0
FMT0: 0
FMT1: 0

maxpou  
#8 Posted : Sunday, February 7, 2021 11:44:25 AM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

someone can help me?
maxpou  
#9 Posted : Saturday, February 20, 2021 2:01:40 PM(UTC)
maxpou

Rank: Member

Groups: Member
Joined: 10/24/2020(UTC)
Posts: 7

Hi,
since my last post I did some tests. first I connected my pcb DAC with a pcm1798 that I had made to work on my I / V stage and it works with the spdif transceiver in 24Bit i2s. Second, I changed the pcm1798 because I thought it was burnt and unfortunately I still had the same trouble. So I reinstalled the COD in my old YBA CD player and set the DIP switches to 16BIT and it works fine. Now I don't understand why the COD and the transceiver don't work together in 24bit I2S, the transceiver works with my 1798 pcb in 24bit I2S and the COD works at 16BIT in my cd player.

Someone can help me?

Thank you Maxpou
Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.